system environment/daemons

nginx-module-nms - NGINX ModSecurity legacy module

Website: https://github.com/dvershinin/ModSecurity
License: BSD
Vendor: GetPageSpeed, Inc.
Description:
ModSecurity is an open source, cross platform web application firewall
(WAF) engine. This is v2.x (old legacy) version.

Known issues:
* "SecRemoteRules cannot be used more than once" emitted upon NGINX reload

Please note that this LEGACY version should not be used if possible!!!
There is a stable, production ready package nginx-module-security which
provides the most recent and stable build of ModSecurity for NGINX.

How to Install

sudo yum -y install https://extras.getpagespeed.com/release-latest.rpm
sudo yum -y install yum-utils
sudo yum-config-manager --enable getpagespeed-extras-mainline
sudo yum -y install nginx-module-nms

Packages

nginx-module-nms-1.21.4.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.21.3.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.21.2.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.21.1.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.21.0.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.10.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.9.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.8.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.7.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.6.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.5.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.4.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.3.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.2.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.1.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.19.0.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.17.10.2.9.3-8.el6.gps.x86_64 [418 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.17.10.2.9.1-2.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support
nginx-module-nms-1.17.10.2.9.1-1.el6.gps.x86_64 [415 KiB] Changelog by Danila Vershinin (2020-04-28):
- fixed up remote rules loading for latest NGINX by integrating unreleased patch for future 2.9.4
- removed explicit Requires, let RPM handle that
- EL6-8 support

Subscribe