nginx extras

nginx-module-security - NGINX Security dynamic module

Website: https://github.com/SpiderLabs/ModSecurity-nginx
License: ASL 2.0
Vendor: GetPageSpeed, Inc.
Description:
NGINX Security module (ModSecurity).

How to Install

sudo yum -y install https://extras.getpagespeed.com/release-latest.rpm
sudo yum install nginx-module-security

Packages

nginx-module-security-1.18.0.1.0.1-5.el7.gps.x86_64 [29 KiB] Changelog by Danila Vershinin (2020-02-20):
- changed serial log from /var/log/modsec/audit.log to /var/log/nginx/modsec_audit.log
- for SELinux compatibility and removed logrotate config (let NGINX one deal with it)
- likewise, concurrent logs /var/log/modsec/nginx -> /var/log/nginx/modsec
- bump up dependency on newer libmodsecurity as they tend to break its ABI
- fix up initial modsecurity.conf having the same directive in multiple places
nginx-module-security-1.18.0.1.0.1-4.el7.gps.x86_64 [29 KiB] Changelog by Danila Vershinin (2020-02-20):
- changed serial log from /var/log/modsec/audit.log to /var/log/nginx/modsec_audit.log
- for SELinux compatibility and removed logrotate config (let NGINX one deal with it)
- likewise, concurrent logs /var/log/modsec/nginx -> /var/log/nginx/modsec
- bump up dependency on newer libmodsecurity as they tend to break its ABI
- fix up initial modsecurity.conf having the same directive in multiple places
nginx-module-security-1.16.1.1.0.1-4.el7.gps.x86_64 [29 KiB] Changelog by Danila Vershinin (2020-02-20):
- changed serial log from /var/log/modsec/audit.log to /var/log/nginx/modsec_audit.log
- for SELinux compatibility and removed logrotate config (let NGINX one deal with it)
- likewise, concurrent logs /var/log/modsec/nginx -> /var/log/nginx/modsec
- bump up dependency on newer libmodsecurity as they tend to break its ABI
- fix up initial modsecurity.conf having the same directive in multiple places
nginx-module-security-1.16.1.1.0.1-2.el7.gps.x86_64 [28 KiB] Changelog by Danila Vershinin (2020-01-30):
- bash script for log rotation of concurrent logs
nginx-module-security-1.16.1.1.0.1-1.el7.gps.x86_64 [28 KiB] Changelog by Danila Vershinin (2019-12-18):
- upstream version auto-updated to 1.16.1.1.0.1
nginx-module-security-1.16.1.1.0.0-2.el7.gps.x86_64 [27 KiB] Changelog by Danila Vershinin (2019-08-16):
- upstream version auto-updated to 1.16.1.1.0.0
nginx-module-security-1.16.1.1.0.0-1.el7.gps.x86_64 [24 KiB] Changelog by Danila Vershinin (2019-08-16):
- upstream version auto-updated to 1.16.1.1.0.0
nginx-module-security-1.16.0.1.0.0-2.el7.gps.x86_64 [24 KiB] Changelog by Danila Vershinin (2019-04-24):
- upstream version auto-updated to 1.16.0.1.0.0
- This is the first release ModSecurity nginx connector.
- fix scriplet
nginx-module-security-1.16.0.1.0.0-1.el7.gps.x86_64 [24 KiB] Changelog by Danila Vershinin (2019-04-24):
- upstream version auto-updated to 1.16.0.1.0.0
- This is the first release ModSecurity nginx connector.
nginx-module-security-1.14.2.1.0.0-1.el7_4.gps.x86_64 [23 KiB] Changelog by Danila Vershinin (2018-12-07):
- upstream version auto-updated to 1.14.2.1.0.0
- This is the first release ModSecurity nginx connector.
nginx-module-security-1.14.1.1.0.0-4.el7_4.gps.x86_64 [23 KiB] Changelog by Danila Vershinin (2018-11-16):
- fix modsecurity.conf log
nginx-module-security-1.14.1.1.0.0-3.el7_4.gps.x86_64 [23 KiB] Changelog by Danila Vershinin (2018-11-16):
- Build using upstream modsecurity.conf-recommended
- Fixed license tag

Subscribe